2019 Springfield TPS or Cylinder deactivation

Discussion in 'Indian Motorcycle Tech Questions & Answers' started by doublej, Apr 1, 2020.

  1. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    2019 Springfield Darkhorse Stage II, 5K miles- Just discovered this on the way to Bike Week. Running 75-85 mph while holding the throttle steady....feels like either a cylinder cuts out, or fuel delivery is reduced (being an old guy, feels like the fuel filter is dirty!)...bike kind of surges.

    Happened in heavy traffic which is not good. Also does it cruising around townCheck engine light goes on. Clears after stopping, and restarting...but happens repeatedly...I have received no error codes other than check engine. Popped into the Daytona dealer and since the check engine code cleared, I got the eye roll and "....you can hang around here all day while we check it out, or you can go ride your bike and it may never happen again...". (...he was a bit condescending...), so off I went.

    Last night, while taking a ride around town- alone- playing a bit (#QuarantineLife)....found that at 4700 rpm's (Standard mode) the engine seems to "plane out" almost like hitting the rev limiter. Went into Sport mode and found it would crank up only to about 5100 RPM's (4th gear) and working hard to get there. Redline is 5300 rpms so somethings wrong. I'm not a big fan of spinning big Vtwins to redline, but this thing is just not running right. Going into the shop on Thursday (bike is under warranty for another year). I'll let you know how we make out. - John
     
  2. Baldhead_J

    Baldhead_J Gold Member
    Original 111

    Joined:
    Jul 29, 2016
    Messages:
    8,365
    Likes Received:
    19,032
    Trophy Points:
    8,193
    I'll be really curious to hear how this works out. I've got a very pesky rear cylinder misfire indicator that I can't seem to track down [2019 BBK].
     
    doublej likes this.
  3. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    Dealer called me today - to let me know that Polaris told them - that if you do not completely roll " off throttle..." when changing gears, the ECM reads an issue and will deactivate a cylinder (assuming it's the rear one). Told me they updated -re-flashed - and the bike runs great.....I'll post an update once I test the bike.
     
    muz, Big A and IROQUOIS like this.
  4. Baldhead_J

    Baldhead_J Gold Member
    Original 111

    Joined:
    Jul 29, 2016
    Messages:
    8,365
    Likes Received:
    19,032
    Trophy Points:
    8,193
    My dealer wrench got the code yesterday as he was moving the bike after the gear indicator recall work. I had him send ANOTHER email to Polaris. I want all of this documented.
     
    IROQUOIS likes this.
  5. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    Picked up the bike, went on a 75 mile ride....bike ran like a champ, ran in two modes - standard and sport. Went out for a hop today....and while riding in Sport mode found the problem came back....was able to make a video while idling ...so anyway back to the Dealer tomorrow!

    On a brighter note, at least I'm not missing any bike events by having it in the shop....!
     
    IROQUOIS likes this.
  6. Baldhead_J

    Baldhead_J Gold Member
    Original 111

    Joined:
    Jul 29, 2016
    Messages:
    8,365
    Likes Received:
    19,032
    Trophy Points:
    8,193
    Mine popped codes for both cylinder 1 & 2, yesterday.
     
    IROQUOIS likes this.
  7. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    Damn!
     
  8. Baldhead_J

    Baldhead_J Gold Member
    Original 111

    Joined:
    Jul 29, 2016
    Messages:
    8,365
    Likes Received:
    19,032
    Trophy Points:
    8,193
    I don't even believe they're accurate reading. I'm curious if anyone with a PV3/PVCX has noticed this condition clearing up.
     
  9. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    That's a great question.
     
  10. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    Being told the front spark plug was loose <which pisses me off since I should have checked it!> and the bike runs great. Will be picking up by Saturday after the Ark leaves port and will report back.
     
    IROQUOIS and Baldhead_J like this.
  11. doublej

    doublej Bronze Member
    Supporting Vendor Original 111

    Joined:
    Aug 8, 2016
    Messages:
    1,536
    Likes Received:
    2,784
    Trophy Points:
    1,193
    Location:
    SC
    This thing runs like a beast.....better than it ever has me thinks.....
     
  12. IROQUOIS

    IROQUOIS Silver Member

    Joined:
    Mar 8, 2017
    Messages:
    3,748
    Likes Received:
    9,699
    Trophy Points:
    3,193
    We twist our minds in knots when the fix is right in front of us.
    I'm so guilty of this!
     
    doublej likes this.

Share This Page